iPod TinyUmbrella

iPod related problems

Moderator: Rapid Repair Team Mods

Post Reply
Posts: 2
Joined: April 8th, 2015, 12:10 am
My Device: iPod touch 4th
I've owned this device for: Over 5 years.

iPod TinyUmbrella

Post by Reaper » April 8th, 2015, 12:26 am

If anyones familiar with Tiny Umbrella I will need your help. My iPod 4th gen went into recovery mode randomly after I tried charging it and I was far from home to do anything at the moment so I waited to get back home. Basically I didn't back up my iPod before so I can't save all my pictures that I'm gonna lose which I need because theirs some of my family. I searched up how to get out of recovery mode and there were many methods, but none worked because it would back into recovery mode, but tinyUmbrella seemed to work for many people, but didn't work for me because no options came up like I saw in the videos.this is how it looks for me.


Im gonna try it out on my relatives laptop, but if you can tell me how to fix it with Tinyumbrella on my computer Ill be very happy.

Posts: 2
Joined: April 8th, 2015, 12:10 am
My Device: iPod touch 4th
I've owned this device for: Over 5 years.

Re: iPod TinyUmbrella

Post by Reaper » April 8th, 2015, 8:36 pm

I just noticed I got an error log after I checked in the tinyumbrella folder
Using Java v1.8.0_40 32 bit
Loaded JAR:C:\Documents and Settings\*****\.tu\.cache\jglooks.ja_
Loaded JAR:C:\Documents and Settings\*****\.tu\.cache\jgcommon.ja_
Loaded JAR:C:\Documents and Settings\*****\.tu\.cache\btip.ja_
Loaded JAR:C:\Documents and Settings\*****\.tu\.cache\glist.ja_
Loaded JAR:C:\Documents and Settings\*****\.tu\.cache\tnail.ja_
Loaded JAR:C:\Documents and Settings\*****\.tu\.cache\jna.ja_
Loaded JAR:C:\Documents and Settings\*****\.tu\.cache\jdom.ja_
Loaded JAR:C:\Documents and Settings\*****\.tu\.cache\lang3.ja_
Loaded JAR:C:\Documents and Settings\*****\.tu\.cache\compress.ja_
Loaded JAR:C:\Documents and Settings\*****\.tu\.cache\xz.ja_
Loaded JAR:C:\Documents and Settings\*****\.tu\.cache\formsrt.ja_
Loaded JAR:C:\Documents and Settings\*****\.tu\.cache\jgforms.ja_
Loaded JAR:C:\Documents and Settings\*****\.tu\.cache\asmc.ja_
Loaded JAR:C:\Documents and Settings\*****\.tu\.cache\asmt.ja_
Loaded JAR:C:\Documents and Settings\*****\.tu\.cache\asm.ja_
Loaded JAR:C:\Documents and Settings\*****\.tu\.cache\l4j.ja_
Loaded JAR:C:\Documents and Settings\*****\.tu\.cache\slfl4jbind.ja_
Loaded JAR:C:\Documents and Settings\*****\.tu\.cache\slfapi.ja_
Loaded JAR:C:\Documents and Settings\*****\.tu\.cache\slfjcl.ja_
Loaded JAR:C:\Documents and Settings\*****\.tu\.cache\json.ja_
Loaded JAR:C:\Documents and Settings\*****\.tu\.cache\jsonm.ja_
Loaded JAR:C:\Documents and Settings\*****\.tu\.cache\jsona.ja_
Loaded JAR:C:\Documents and Settings\*****\.tu\.cache\bc.ja_
Loaded JAR:C:\Documents and Settings\*****\.tu\.cache\g.ja_
Error executing [createDeviceMenuItemWithInfo([class com.semaphore.tu.service.Device, class java.lang.String, class java.lang.String, class java.lang.String])] [java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.semaphore.notification.TinyNotification$_TinyHandler.handleNotification(TinyNotification.java:271)
at com.semaphore.notification.TinyNotification.lambda$postNotification$21(TinyNotification.java:196)
at com.semaphore.notification.TinyNotification$$Lambda$73/20803984.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.IllegalStateException: AutoCompleteSupport must be accessed from the Swing Event Dispatch Thread, but was called on Thread "pool-1-thread-9"
at ca.odell.glazedlists.swing.AutoCompleteSupport.checkAccessThread(AutoCompleteSupport.java:479)
at ca.odell.glazedlists.swing.AutoCompleteSupport.install(AutoCompleteSupport.java:779)
at com.semaphore.tu.TinyDeviceDialog.<init>(TinyDeviceDialog.java:50)
at com.semaphore.tu.TinyApp.createDeviceMenuItemWithInfo(TinyApp.java:664)
... 10 more

Post Reply