120gb Zune Black Screen on Startup

Zune Parts, Discussion, Upgrades & Repair

Moderator: Rapid Repair Team Mods

Post Reply
collapsiblbunny
Noob
Noob
Posts: 1
Joined: October 18th, 2014, 2:39 am
My Device: Zune
I've owned this device for: Over 5 years.

120gb Zune Black Screen on Startup

Post by collapsiblbunny » October 18th, 2014, 3:12 am

I've never posted here, but I just spent a significant amount of time searching through the forum for help.
My 120gb Zune is an old girl and she's been through a lot. The most recent modification (which took place in April of 2014) was the installation of a brand new hard drive. It's always trucking along and never giving me issues. But the other day I went to turn it on and it started up with the Zune logo, which typically happens to me whenever it's been stored in lower temperatures (leaving it in the car over night or something of the like). The issue is that after displaying the logo and watching the loading bar climb, the screen went black and never progressed to the menu. The black screen remains lit up.
I've reset it. I've let the battery drain. I've recharged the battery. The only thing I haven't done is attempt to reformat it. This is due to the fact that around the same time my Zune took a turn for the worse, my laptop did as well, meaning that I have no music unless I can revive one of them. This is beside the point.
I realize this topic has been brought up a lot, but the reason I bring it up again is that despite how many people I see having this issue, everybody seems to have a different back story or series of events leading up to it. I've heard it could be hardware or software.
I'm less inclined to believe it's the hard drive as I've just replaced it pretty recently. However, when it was replaced, the person who replaced it broke a couple of the clips on the inside so the case is never fully clasped together. Could it be possible that something is just disconnected from traveling around with a less than functional case? Any input would be appreciated.

RapidRepair
Founder
Founder
Posts: 286
Joined: February 3rd, 2006, 6:09 pm
Location: Kalamazoo, MI
Contact:

Re: 120gb Zune Black Screen on Startup

Post by RapidRepair » August 15th, 2016, 4:51 pm

Sounds to me like the LCD just needs to be replaced!

Post Reply